РезультатЗапроса = Запрос .Выполнить ();
ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
Пока ВыборкаДетальныеЗаписи.Следуюший() Цикл
Н = 0 ; // для того, чтобы запомнить - такой строки нет
Если ВыборкаДетальныеЗаписи.КолВЗК <> Справочники.ПодразделенияОрганизаций.ПустаяСсылка() Тогда
Для Каждого Стр Из Коэффициенты Цикл
Если Стр.Отделение = ВыборкаДетальныеЗаписи.КодВЗК Тогда
Стр.БД = Стр.БД + ВыборкаДетальныеЗаписи.УЕТВрача + ВыбсркаДетальныеЗаписи.УЕТМедсестры;
Н = 1;
Прервать;
Иначе
Н = О;
Продолжить;
КонецЕсли;
КонецЦикла;
Если Н = 0 Тогда
СтрТабЧасти = Коэффипиенты.Добавить();
СтрТабЧасти,Отделение = ВыбсркаДетальныеЗаписи.КодВЗК;
СтрТабЧасти.БД = ВыборкаДетальныеЗаписи.УЕТВрача + ВыборкаДетальныеЗаписи.УЕТМедсестры;
Сообщить("В табличную часть добавлена строка с отделением: " + ВыбсркаДетальныеЗаписи.КодВЗК);
КонецЕсли;
Иначе
Сообщить("В отделенении" + ВыборкаДетальныеЗаписи.НаименованиеПодразделенияОказавшегоУслугу + " не проставлен код ВЗК. УЕТ этого отделения в документ не добавлено ");
КонецЕсли;
КонецЦикла;
Комментарий=? (СокрЛП(Комментарий)="","",СокрЛП(Комментарий)",") "УЕТ из ТОКОМЕД";

IrbisProg

Решения для современной бухгалтерии

Ознакомиться подробнее

IrbisProg - конфигурации на языке 1С